HTML Tags affecting PHP code visibility MELite 08

Home Forums Multi-Edit Lite Support (Lite) HTML Tags affecting PHP code visibility MELite 08

This topic contains 7 replies, has 3,971 voices, and was last updated by  natfox 5 years, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2844

    natfox
    Participant

    New to using MELite, but whilst viewing php files, every time a > appears in the text, code highlighting appears to stop working and the code goes back to black – how do I stop this happening? Also, the colours of the highlighted code are green and red whereas for php code I would expect to see blue and orange also?

    #9231

    Clay Martin
    Keymaster

    Hi,
    Can you provide a code sample, I am unable to reproduce the problem.

    As for colors you can go to Tools-Customize-Colors and modify the colors used. Just remember to hit save. Also in Tools-Customise-Extensions, select PHP and press the edit button, there is a setting to select the color set for all php files.

    Thanks,
    Clay

    #9232

    natfox
    Participant

    Hi,

    Thanks for your reply.
    Here is an image of a snippet of code that illustrates this.
    Capture.JPG

    #9210

    Clay Martin
    Keymaster

    I used that code snip and was not able to duplicate the behavior. You might want to check your word delimits. That’s in Tools-Customize-Editing and they should look like this:
    |9|1 .()"’,$@!%^&*{}[]?/||;:+-<>~

    Thanks,
    Clay

    #9199

    natfox
    Participant

    I’ve checked Editing and the Word delimits reads exactly as you specified in your last reply.

    The problem still exists so any other possible solutions would be appreciated.

    Thanks very much.

    #9217

    Clay Martin
    Keymaster

    Hi,
    Can you go to Tools-Custoimize-General press the language button, select PHP and then press the edit button, then post a screen snap of that dialog?
    Thanks,
    Clay

    #9263

    natfox
    Participant

    Language Setup screen
    Capture1.JPG

    #9249

    Clay Martin
    Keymaster

    Hi,
    All your language settings seem to be the same as the factory defaults (that I am trying to use to duplicate the problem). Under the language setup there is a formatting/config button. Are any but the first 3 check boxes checked in that dialog that appears after pressing that button? I also just noticed that in the default highlighting color settings, brown (as in the if ($setregion code in your screen snap) is used for comments, code, like the if statement, is black. Have you changed the color settings? Maybe you can provide a larger sample of the code around where the problem occurs in a text file (txt) attached to a post.

    Thanks,
    Clay

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.