Activating Toolboxes

Product Compare Forums Multi-Edit Support Activating Toolboxes

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #779
    jhobbs
    Participant

    Windows XP, MultiEdit 9.0e

    The correct toolboxes are displayed when editing .html code, but only a couple of the icons are active. How can I activate everything that’s appropriate?

    My Extension setup Language and Template are “HTML”. Switching the template to Weblair doesn’t help. What’s forcing the icons to be inactive? :?

    #3054
    ReidSweatman
    Participant

    From the main menu, open Tools | Customize | Weblair – web editing. In the listbox on the right titled Tag databases at least one of the items should have a red check next to it. If not, that’s the problem. Select one and click on the Use button. You can do this with more than one, if you want to have multiple databases active. For instance, Html4 will give you the most common HTML tags, while ColdFusion will give you tags specific to ColdFusion files.

    Many of the buttons on the Weblair toolbars invoke functions that are dependent on one or more of these tags, so not having a tag database in use will prevent many of the buttons from working correctly. Often, they’ll simply do nothing at all when pressed, which sounds like the problem you described.

    #3056
    jhobbs
    Participant

    HTML4 has a red check.

    Actually, now everything is working, when I switch the language to HTML. I had copied the HTML language to HTMLCopy, in an effort to avoid mucking up Multi-Edit’s pristing code. It turns out that associating the extensions with “HTML” language works, but associating with a copy of “HTML” doesn’t.

    So now the mystery is, why is using a copy of the HTML language different from using HTML?

    #3058
    DanHughes
    Participant

    The reason most of the Html toolbar buttons are disabled is because they have a setting in their command map entry to only be enabled when the file is associated with a language called HTML. See the Disabled identifier field of the command map for any of the disabled toolbar buttons. The identifier should read /LS=HTML.

    #3059
    jhobbs
    Participant

    :oops: Of course!

    Thanks for your help!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.