Controlling Matching quotes

Product Compare Forums Multi-Edit Support Controlling Matching quotes

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2468
    vmaiz
    Participant

    This is probably language-specific, but I haven’t been able to find how to
    turn this feature on/off when your editing requirements change…
    Any suggestions would be appreciated…
    Thanks

    #8251
    deleyd
    Participant

    There are some controls deeply buried. They are language specific.

      [*:qvl7yic5]TOOLS -> CUSTOMIZE -> GENERAL(left side) -> LANGUAGES[/*:m:qvl7yic5]
      [*:qvl7yic5]select language and click ‘Edit’ (right side top)[/*:m:qvl7yic5]
      [*:qvl7yic5]In the resulting ‘Language Setup’ dialog, down in the lower right corner, click ‘Formatting/Config'[/*:m:qvl7yic5][/list:o:qvl7yic5]If you don’t get a new ‘Properties Setup’ dialog, there may be no setup options for that language. Most of the languages have a ‘Properties Setup’ dialog for them where you can check/uncheck things like "Highlight Matching Parenthesis."

      If you don’t get a new ‘Properties Setup’ dialog, look above the ‘Formatting/Config’ button to the ‘Macros’ section and see if there are any entries. If the ‘Config’ field is blank there, then there’s no ‘Properties Setup’ dialog for that language (rare).

    #8253
    vmaiz
    Participant

    Were you able to control your quote behavior this way? I couldn’t in my MEW.
    I should have mentioned yesterday that my MEW is 9.10/WinXP and that I did
    experiment with language setups. My language is BASH scripts, temporarily using the PERL setup with config screen and macros. Always echoes ‘/" quotes, regardless of macros or any matching dialogs. So do other similarly structured languages. I double-checked PERL language support s-file in Src/ – saw nothing there in the code that automatically would echo quotes. Today, after reading your note, looked at my TXT extension setup (almost nothing there) – still echos quotes… But when I load a new window with an extension that’s not on the file-type list, eg. file x.y – quotes are not echoed when I enter them. Save file and reload – and they are echoed again.
    Fascinating if it weren’t such a drag. Combining Overwrite with quote-echoing tends to introduce bugs when working with explicit strings a lot…
    I will have to look some more when I get a chance.
    But Thanks for your suggestion all the same.

    #8254
    DanHughes
    Participant

    Do you have the Evolve AddOn installed? If you do then that is probably what is causing the insertion of the closing quotes. To turn this feature off run the following macro.

    ev_confg^evConfig

    Then uncheck the appropriate Auto … Closure option.

    #8257
    vmaiz
    Participant

    That was definitely it, Mr. Hughes!
    Are there are NO more mysteries left for you in MultiEdit?
    I was wondering when you were going to take crack at my problem.
    I was not aware, of course, of the macro, or the ability to control the feature.

    I have also found same problem among Support topics under
    "Turn off auto quote"

    Thank you for your expert help

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.