Copy and Paste Line – Not at Cursor Position

Product Compare Forums Multi-Edit Support Copy and Paste Line – Not at Cursor Position

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2934
    Notebooker
    Participant

    I know I had it set up before so that I could have my cursor in the middle of a line. Highlight the whole line with CTL-DownArrow, then do a CTL-V right from the same spot, and it would insert an exact copy of the whole line, just above or just below the current line with the first columns of both lines lining up to the left.

    Now when I try it, it inserts the new line beginning at the cursor position instead of making a complete new line.

    I cannot find that setting and now whenever I try to do that, it pastes the new line with the first column starting at the cursor position.

    Any insight on that one?

    Thanks!

    #9490
    Notebooker
    Participant

    I can see that when the cursor is at column 1 it acts just like it used to, inserting the new pasted line above the highlighted line. Is there a setting that involves copy and paste of a line that automatically sets the cursor to column position 1?

    #9491
    Clay Martin
    Keymaster

    Hi,
    What command is Cntl-Down assigned to? One of the things that effects copy past operations is what block mode you are in, Stream, column or line. These can be set in Edit-Mark (line, block or column) also by right clicking after you have selected some text. Also under Tools-Customize-Editing-Blocks there are a number of settings that effect copy paste operations.

    Thanks,
    Clay

    #9492
    Notebooker
    Participant

    I think you hit the nail on the head but… I cannot find – "Edit-Mark (line, block or column)" – anywhere!

    I just did a re-install of my older version a few days ago. It starts with v9.0 I think then I applied the upgrade to make it 9.0e. It used to have this setting I’m sure, but I cannot find it anywhere now. When I check my version in Help, it says 9.0e.

    I’ve looked all through the Tools-Customize-Editing and all three of the context sub-menu items under "Customize this files settings" when I right click on some highlighted text. – "Extension setup", "Edit templates", "Language setup". I have not been able to locate this setting.

    (Sorry, I meant "Shift-Dn" rather than "ctl-dn". My Shift-Dn is mapped to "Shift Cursor Keys 1" – ShiftCursor macro.)

    #9493
    Clay Martin
    Keymaster

    Hi,
    Looking at the help file in block operations I found this:

    · To create a stream block using the keyboard, hold the SHIFT key while using the RIGHT or LEFT arrow keys.

    · Creating a line block is dependent on the option "Shift+UP/DOWN begins line block" located under Tools | Customize | Editing | Blocks. When enabled, pressing SHIFT and the UP or DOWN arrows keys will begin line blocking.

    · To create a column block press SHIFT+F7 to start the block then use the ARROW keys to encompass the text followed by SHIFT+F7 to end the block.

    [/quote:yoia2qa7]

    So it looks like you were marking a line block.

    In Menu item Tools-Customize- Editing-Blocks there is a setting (right side of dialog) Leave Cursor at. The options are start or end of pasted text. This may effect what you are doing. Also in the main options area on that dialog there is an option Shift+up/down begins line block. You would want that checked. There are also some other options that may effect what is happening, such as persistent blocks and turn highlighting off after copy. I can’t tell what your dialog looks like exactly as I don’t have V9 around anymore.

    On the edit menu, under Block operations there are 3 checkable items, Mark Line, Mark Column, Mark Stream. You can be in one of these modes at a time and they effect how copy/paste operations happen.

    Also you might want to check the settings for the extension of the file you are editing and make sure edit mode is text not document.

    Clay

    #9506
    Vincentcnbres
    Participant

    Is there a setting that involves copy and paste of a line that automatically sets the cursor to column position 1?

    #8234
    Clay Martin
    Keymaster

    Hi,
    In Tools-Customize-Editing-Blocks there is a setting to leave the cursor at the beginning or end of pasted text.

    Thanks,
    Clay

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.