File associations

Product Compare Forums Multi-Edit Support File associations

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1412
    dowdp
    Participant

    Recently upgraded from WIN98SE to XP. Having problems changing the file associations so that when I click on a .PRG file it opens with ME 9.10.

    Using the “Open With” dialog, XP recommends opening them with ME 8.x or another program. I use “Browse” to navigate to the ME 9.10 directory and select MEW.EXE and select Open. When back at the initial menu it still opens the file with MEW.EXE for ME 8.x.

    Is it because the .EXE name is the same even though the path is different?

    Patrick

    PS Yes, I am set up as “Administrator” in XP.

    #5051
    Ken Walker
    Participant

    Patrick,

    I experienced a similar issue when upgrading my version of ME. Per Microsoft’s site, you are doing the correct thing to try to change it. However, try this as well: Open the Control Panel and select Folder Options. Click on the File Types tab at the top of the window. Scroll down to the .prg extension and associate it to something like Notepad. Exit the control panel and locate a prg file, double click it and make sure notepad opens it. Then go back in and change it to the new version of ME.

    Hope that helps.

    #5053
    Carloche
    Participant

    Is it because the .EXE name is the same even though the path is different?[/quote:15z1ms4t]

    Possibly. If what Ken suggests doesn’t take care of the issue, there is one other thing to look at. First, know that we never recommend mucking about in the Registry and only to go in there as a last resort. Also, make sure before doing so you backup your registry.

    That said, the following registry key may be holding an incorrect/old path for ME.

    HKLM\Software\Microsoft\Windows\CurrentVersion\App Paths\MEW32.EXE

    Check and correct that if necessary.

    #5086
    ReidSweatman
    Participant

    Sort of a guess, but versions of Multi-Edit prior to 9.10 maintained a “last-used-location” path under the HCU\Software\American Cybernetics key (which doesn’t exist for current versions, but can interfere with them). I had some trouble with that a year or so ago; it’s worth fiddlin’ with (but always back up the registry key, or the entire registry, before sticking your head under the hood!)

    #5137
    LarryEdwards
    Participant

    Reid,

    I am having the same problem. The reg entry (details above) under HKLM is set the the “04” version and there is no HCU entry for Multi-Edit.

    If I rename the directory for the “03” version so it is inaccessible by file association I get an error. If I then associate a file extension with the “04” version using my Win Explorer work-alike (PowerDesk), the file loads from the Association menu in MEW 9.10.04.

    However, susequent attempts to load files of that extension fail until I rename my “03” version directory back to its old name. Then files load into “03,” as before. The only way I can access “04” is with a “Sent To” from the right click menu of PowerDesk.

    ??? I’m not ready to uninstall “03” yet, so how do I get “04” to take control?

    — Larry

    #5140
    Carloche
    Participant

    Have you unchecked the Associate to Desktop Shell for the PRG file extension in your .03 version and set it in your .04?

    #5141
    LarryEdwards
    Participant

    Carloche,

    I just played with “Associate to Desktop Shell,” but I still can’t make files load to .04.

    I had none of these boxes checked in .03 (didn’t even know they existed), and in .04 I now have the boxes checked for the PRP and TXT file extensions. (Don’t know why you specified PRG since I don’t have any of those, but did it anyway).

    Then I tried loading a TXT file, but it still loads into .03.

    — Larry

    #5142
    Carloche
    Participant

    Sorry, I had associated your response with the initial posting by dowdp referring to PRG files…still looking into it and trying to reproduce. Above steps should get you where you need to be, though. Also, make sure after associating files, you restart Windows as that can be an issue as well.

    #5143
    LarryEdwards
    Participant

    I restarted Windows, the association was still to .03. I then did a new file association from PowerDesk (via the “Open With” dialog box), and now have the association set to .04 successfully for .txt files.

    I then tried an Open With for .ini files. No go. So I set the Associate to Desktop Shell in MEW. Still no go. Tried Open With again — still no go.
    Tried Open With a second time — that time association was successfully set to .04.

    Suggestion: Make an option in MEW to disable the “Associate to Desktop Shell” feature for file extensions, with a default to use whatever association is setup from the desktop (or Windows Explorer-oid). If this option is selected (actually it should be the default selection, I think), the “Associate to … Shell” item would be greyed-out with the box checked. The existing MEW feature is simply too complex unless it is really needed under special circumstances, and adds difficulty to upgrades.

    Thanks for your help,
    — Larry

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.