Hangs when searching

Product Compare Forums Multi-Edit Support Hangs when searching

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2938
    HumanPotato
    Participant

    Hello,

    I have been using ME2008 (v 11.00.00) for several years without issues, but recently I am experiencing problems searching.

    I can search the currently opened file for a single search string one at a time and the editor behaves as expected. However, as soon as you click on the "ALL" button from within the search dialog the editor hangs and I have to shut it down. This also occurs when performing a "file find", regardless of where the file is located (network drive or local hard drive).

    I have tried recompiling "search.s" but this had no effect. Other editors are able to search without any issues. I have not installed anything new recently or made any other changes to my system. Upgrading the editor is not an option as I work in Government so any upgrade will take months to occur. Attempting to run "Recompile Macro Source" ends in an "Output File Error" (I can’t see the exact issue as the window is too small and cannot be resized).

    EDIT: When only working on the currently open file, search and replace works just fine when I click ALL, (but hangs if click ALL on the "find" tab). I am using Windows XP professional

    Where do I go to from here?

    #9497
    Clay Martin
    Keymaster

    Hi,
    Sou nds like the find results file is corrupted. Go to View-Find List 0, if the entry is not checked please click on it. Then in the find list pane (below the edit window).
    Click on the little arrow in the upper left corner of the pane and then choose clear all.
    Repeat this for Find List 1.

    If this does not work, then in file manager, locate the config directory (the following post tells you how) and in the Tmp directory, under the Config directory delete the following files. Multi-Edit should not be running when you do this.
    viewtopic.php?t=2013
    The files
    Mefind1.tmp
    Mefind0.tmp

    That should solve your problem.

    Thanks,
    Clay

    #9498
    HumanPotato
    Participant

    Hello,

    I was unable to view find list 0 or find list 1. Attempting to do so caused ME to hang.

    I followed the instructions to find the config folder, which came out as:

    [code:3bp1inas]c:\Documents and Settings\ub6q3\Application Data\Multi Edit Software\11\Config.00\[/code:3bp1inas]

    Mefind0.tmp was located in a directory under config.00 named "Bak". I deleted it (and later on, did the same for every other .tmp file).

    Restarting ME, I still cannot view or clear the search results without ME hanging. Everything else about the editor appears to be working fine.

    EDIT: I have found that by changing all my search tabs to "Find List 1" it works fine. It appears that the only problem is with "Find List 0".

    #9499
    HumanPotato
    Participant

    Well I’ve spent the day doing more trouble shooting. It turns out that my copy of ME writes the "MeFind0.tmp" to the C:\Temp\ folder (probably due to the crazy network install we have here). I only discovered this by accident when I ran "SWITWIN /SYSTEM=2" while I had search results in FindList1 visible and noticed the folder in which it was stored.

    I deleted the file and it is now back to working correctly and I can search to my hearts content.

    Thanks for your help :)

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.