How to change Work Directory

Product Compare Forums Multi-Edit Support How to change Work Directory

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #21626
    RwsRichard
    Participant

    When I go to ‘Open or Save’ a file in ME2008, it defaults to:
    ‘Work: C:\Program Files (x86)\Multi-Edit 2008’

    How can I permanently change the ‘Work:’ directory?

    Checking ‘save in last directory’ does seem to work.

    #21628
    Clay Martin
    Keymaster

    Hi,
    When you first install Multi-Edit (ME) the working directory is set the install directory. If you use Projects, that will set the working directory to the project directory.

    In Tools-Customize-Files there is a setting for “File Path” with several options.

    Your last working directory is kept in the session file, there are a number of settings for how your sessions are kept.

    Finally, on the file open dialog, near the bottom: Work (working directory) Field

    The Work field contains the current working directory. To the right of this field are two buttons, which allow the working directory to be set, or displayed in the file list view and directory tree view.

    Hope this helps,
    Clay

    #21629
    RwsRichard
    Participant

    Thanks Clay for the reply, but NONE of those options work.

    Every time I choose to open/close/save a file, it goes to the original install directory and I have to work my way to the correct folder.

    I want to PERMANENTLY change the original install directory to something else, like one of my working directories.

    #21630
    Clay Martin
    Keymaster

    Hi,
    Some things to check on in Tools-Customize

    In Sessions do you have “Save named sessions only”
    What do you have selected for “restore status method”

    In Files, what do you have selected for “file path”

    If you go to the link/icon/etc that you use to start Multi-Edit (ME) and right click and select properties. Does the command line have /SR on it? This it the flag for session restore.

    Have you tried changing the working directory on the open dialog by using the change button?

    Thanks,
    Clay

    #21634
    RwsRichard
    Participant

    In Sessions do you have “Save named sessions only”
    I have “Restore screen position at startup” and
    “Save named sessions only” checked.

    What do you have selected for “restore status method”
    I have “Status file in each directory” checked

    In Files, what do you have selected for “file path”
    I have: “Use path of last loaded file”

    If you go to the link/icon/etc that you use to start Multi-Edit (ME) and right click and select properties. Does the command line have /SR on it? This it the flag for session restore.
    My properties info shows a -SR on the end, NOT /SR

    Have you tried changing the working directory on the open dialog by using the change button?
    Yes, but the change button does not work all the time. I sometimes find myself back at the original work directory even though the work directory shows another directory. AND after using the change button when I exit Multi-Edit and then later start Multi-Edit, I am back at the original work directory.

    Thanks,
    RwsRichard

    • This reply was modified 6 years, 1 month ago by RwsRichard.
    #21642
    Clay Martin
    Keymaster

    Ok, Now we are getting somewhere. The fact ME reverts to the install directory when you restart is because you have save only named sessions selected. To name a session you need to use File-Session Manager, or Projects tied to sessions. Because you have that checked and haven’t named a session it is not kept between restarts. If you uncheck that unnamed sessions will be kept. -SR is the same as /SR.

    Reverting in the middle of a editing session may be because of that setting and the fact you switched away from ME to another app, then back. Not sure because I can’t duplicate that.

    You may find using projects and sessions together will work well for what you do. Here is a tutorial
    https://www.youtube.com/channel/UCfblShqr1cnltnafgzEy6HQ?view_as=public

    Thanks,
    Clay

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.