Linux progress?

Home Forums Multi-Edit Suggestions Linux progress?

This topic contains 44 replies, has 54,185 voices, and was last updated by  deleyd 10 years, 7 months ago.

Viewing 15 posts - 31 through 45 (of 45 total)
  • Author
    Posts
  • #7752

    John Martzouco
    Participant

    Here’s another question:

    GNOME or KDE?[/quote:3evhqsj3]

    That’s a choice you’ll have to make as you play with the systems. Both will give you a desktop experience… you’ll most likely end up learning something about one or the other that you prefer… eventually, you’ll find something unique about each one that excels the other.

    Linux is full of choices like this… makes it hard to get started.

    As a rule of thumb… take the defaults with whichever system you install. Your chances are best that this is the option the developers have spent most time on and that works best.

    #7753

    John Martzouco
    Participant

    If your local computer is *nix then you can mount remote volumes. I know this works if the remote volume is on another *nix flavor. The ability to do this might require that the remote volume is a particular format (I don’t think FATx would be supported) I haven’t looked into this in a long time and *nix has moved a lot toward compatibility with win. Maybe someone else is more familiar with *nix-win relations.[/quote:2uh8mtdj]

    DSL has no issues with FAT file-systems. I’m sure that any mainstream distribution today will stand up to that. NTFS might be a challenge, but I’ve seen mention of it and am pretty sure there are solutions available.

    When I run cfdisk (the Linux equivalent of fdisk) I can see about 60 different file systems available to choose from in DSL. I didn’t realize that there were more than the four or five we use in Windows before.

    #7754

    deleyd
    Participant

    Well let’s see, so far I’ve tried these and they all hang somewhere during boot:[list:3ud6hqs1][*:3ud6hqs1]Ubuntu 7.04[/*:m:3ud6hqs1][*:3ud6hqs1]Ubuntu 8.03alpha3[/*:m:3ud6hqs1][*:3ud6hqs1]Mandriva[/*:m:3ud6hqs1][/list:u:3ud6hqs1](guess I spent the whole rest of the day doing those things that have to be done but don’t count, along with this cold that’s getting worse.)

    DSL is the only one that worked, but I don’t know what to do with it once it came up. Firefox didn’t connect, other disks weren’t visible.

    #7755

    John Martzouco
    Participant

    DSL is the only one that worked, but I don’t know what to do with it once it came up. Firefox didn’t connect, other disks weren’t visible.[/quote:3b3ophrl]

    Running under virtualization, you’ll be interfacing with Windows systems using Samba.

    Glad you’ve gotten that far, here are some pointers to get you connected with your data.

    1st) Networking:

    In DSL v3.4…
    click on the desktop icon named DSLPanel /
    then click on the button labelled Netcardconfig /
    enter a static IP address into the Address IP field /
    enter your gateway server’s address in the Gateway field /
    enter your DNS server’s (I use the same as my Gateway) in the first Nameserver field /
    select ‘no’ for saving the configuration (until you’ve done this a few times and you know you have the data right) /
    click the Apply button

    You should see the new address show up on the top-right of the desktop after about 5 seconds (they call the program that displays all that info Torsmo)

    Now you can try using Firefox to see if your network is working.

    2nd) Accessing Data:

    You have a few choices here, but let’s start with the fundamentals. Let’s decide to keep DSL files seperate from Windows files for now. This will help you get used to Linux and you won’t lose any data outside of your little controlled environment. We’ll be using a small utility in DSL that offers the subset of Samba features needed to ‘pull’ files from a machine running Windows and sharing out a folder. This will work under virtualization as well as with any other machines on your network.

    Open up a console by clicking on the icon labelled ATerminal on the desktop /
    type in smbclient \\<ip_address>\<shared_folder_name> -U <username> This connects you to a shared folder on a Windows machine
    now type in get <filename> and the file from your Windows machine will be copied to the folder where you started up the smbclient command. Se for more info about smbclient /
    type exit to get out of smbclient /
    type ls to list the files in your current folder, which should now include the file you fetched from teh Windows machine

    The first file you’ll want to copy up is the wine-0.9…uci file I mentioned in the last post. The second file you’ll want to copy up is notepad.exe or some othe small utility you can use to start testing.

    3rd) Getting Wine installed:

    click on the MyDSL icon /
    click on the LoadLocal button /
    select the wine-0.9…uci file from the folder you brought it to with smbclient (this will probably be in the /home/dsl folder) /
    after Wine is installed, start an ATerminal console /
    navigate to the folder containing notepad.exe /
    first, type in the command winecfg. This will create the mock Registry file and system settings for Wine. If you get a dialog that pops up, just accept all the defaults /
    now that Wine is configured, you’ll want to try running wine notepad.exe

    #7756

    deleyd
    Participant

    Looks like I’m going to keep Kleenex in business for another year with this cold.

    I found the DSL – Networking Config dialog. Interface says etho. Don’t know what that means. I set to Use DHCP Broadcast, which grays out everything else. But that’s not enough to connect. This is a laptop with a wireless, and there’s a password for the wireless encryption I need to tell it somewhere.

    (Looks like my main desktop monitor, a 22" widescreen, is what went kaput. Bought it just last April. Can’t find the receipt for it. Just my luck. I probably put the receipt in a "safe" place. Wonder if the credit card company has a record? CompUSA I bought it from is going out of business. They’re selling the fixtures and everything. (Got a good deal on clipboards.))

    What’s Samba? OK, I’ll go investigate that.

    My goal is to get Multi-Edit running on Linux by the end of February. (Just my luck, February is a short month.)

    #7757

    John Martzouco
    Participant

    David, have you tried running under VirtualPC?

    Here are the setups from my systems:

    1) DSL under VirtualPC with DHCP server running:

    Automatic network connectivity; no user setup required.

    2) DSL under VirtualPC without a DHCP server:

    User must assign static IP address using Netcardconfig.

    3) DSL as the base OS:

    I found the DSL – Networking Config dialog. Interface says etho. Don’t know what that means. I set to Use DHCP Broadcast, which grays out everything else. But that’s not enough to connect. This is a laptop with a wireless, and there’s a password for the wireless encryption I need to tell it somewhere.[/quote:1347xjdx]

    eth0 is the name that Linux assigned to a piece of hardware on your system. When we get your card running, we’ll be looking for a name like ath0 or wlan0.

    Wireless works with a lot of cards on DSL, but not all. Take a look at . You’ll need the Windows driver files; *.sys and *.net from your card’s setup disk for ndiswrapper.

    Once we get the hardware running, we’ll assign the WPA settings using another utility, named . If you’re using WEP, it’ll be something else. All the utilities are already included in DSL.

    You can read to get an idea of how it goes.

    It’ll be a lot easier for you to transfer files to that machine using a USB key… in fact, it’ll be simpler if you just store them on the key instead of in DSL’s file system for now. Stick the key into the slot, wait a few seconds and then run mount /dev/sda1 from a console. Like eth0, sda1 is the name Linux assigns your USB device. It could be sda2, but 99% it’ll be sda1. Once it’s mounted, you access it by the path /mnt/sda1.

    The USB solution will get you going, as the network setup for wireless will eat up a fair amount of time.

    #7759

    deleyd
    Participant

    I switched to trying the 32-bit versions of Linux, since the 64-bit versions didn’t work, even though this is an AMD Turion 64 cpu. I’m having more success with the 32-bit versions.

    I got Ubuntu Hardy 8.03 alpha 4 to boot. But when I go to set up networking, it demands I enter the administrator "password", and I have no idea what the password is.

    #7760

    John Martzouco
    Participant

    Search the Ubuntu forums and fnd out what the default superuser (root) password is.

    #7762

    Clay Martin
    Keymaster
    #7783

    Tim Pearce
    Participant

    For some reason I have not been getting notified of updates to this thread.

    I’ve been using Multi-Edit on Linux using the patches David created with very few real problems.

    A quick way to get Linux on your Windoze PC is to install the VMWare player, which is free from [url:m2sfcbpc]http://www.vmware.com/download/player/[/url:m2sfcbpc], then head over to the Canned OS Project at [url:m2sfcbpc]http://canned-os.blogspot.com/[/url:m2sfcbpc] and pick a pre-built virtual machine. (on the right hand click ‘Show All Of Our Releases’ to see a selection of them)

    As for installing WINE, I would suggest going over to CodeWeavers at [url:m2sfcbpc]http://www.codeweavers.com[/url:m2sfcbpc] and paying the, modest, $40 for the standard version of CrossOver. CrossOver is the commercial version of WINE and your purchase of CrossOver essentially supports WINE.

    CrossOver has ‘bottles’, which are basically just separate WINE environments. I have a separate WinXP bottle for MEW on one PC and am using my default Win98 bottle on the other.

    For MEW, you will probably need to install ‘Windows OLE components’, ‘Core Fonts’ and ‘Internet Explorer 6 SP1’ (IE7 does not work under WINE) before installing MEW.

    Tim

    #7784

    Tim Pearce
    Participant

    David,

    I applied that last change, the Find still gives me ‘Error #5001 Macro or Macro file "LNX&_SEARCHDLG.mac" NOT Found ….’
    (yes it is a &, not a $), but the normal (non-Linux) search works !

    Tim

    #7794

    deleyd
    Participant

    This is the latest. (Actually it’s a month old. Thought I had posted it but don’t see it here, so I’m posting it.) Let me know if there are any problems with it.
    LinuxMenu 1.01.zip

    #8275

    deleyd
    Participant

    I’m working on a new Linux Add-On. Someone fixed a bug a few months ago and I discovered Multi-Edit runs on Crossover now.

    #8277

    Tim Pearce
    Participant

    David,

    I’ve been using Multi-Edit ‘for real’ on Crossover since about the time you created this add-on.

    Are you using Multi-Edit on Crossover? There are still a number of annoying problems, which you would be aware of if you are using it. If not, I can list them for you.

    Come to think of it, I think I’ll make a list and post it here regardless, but that will have to wait – it’s almost 7am here and I have to get ready for work.

    Tim

    #8278

    deleyd
    Participant

    Tim,
    Thank you for writing. About half a year ago I wasn’t able to get Multi-Edit to install. It just kept crashing whenever I exited. Then just recently I tried it again, with the newest edition of ME2008, and I think I upgraded CrossOver, half a year ago and then never used it. Anyway it didn’t crash this time around. I think there was some bugfix in ME2008 11.00 .

    Let me get this new add-on finished, and I’d love it if you would try it and give me feedback, because I probably won’t actually use it on Linux much. (Or who knows, I hate Vista so much, nothing works on Vista, maybe having Multi-Edit working on Linux will change things for me.)

Viewing 15 posts - 31 through 45 (of 45 total)

You must be logged in to reply to this topic.