My "copy-and-paste" bug is back!!

Home Forums Multi-Edit Support My "copy-and-paste" bug is back!!

This topic contains 19 replies, has 10,866 voices, and was last updated by  LarryEdwards 7 years, 8 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #2226

    Gorlash
    Participant

    This is driving me NUTS!!! I had been evaluating me2006 for a week or so, predominantly to make sure my famous copy-and-paste bug was gone, and it appeared to be gone indeed. So I upgraded a few days ago (from mew9e), and installed the new version on my WinXP SP2 (actually MCE 2002). I tested c&p operations all day yesterday, and they worked fine. I c&p’d from FireFox, my telnet program, and from 4nt console prompt… all worked fine.

    Suddenly, today, the d#@&# bug is back!! Here’s what happens: I’ll highlight some text in another program, and use the appropriate commands to copy to clipboard (usually Control-C, but when testing I use edit-menu commands to do the copy whenever possible).

    Then I go to ME, click in a document, and hit Insert to paste. (BTW, I use the Brief keyboard emulation) This *should* work, and yesterday it did. Today, it doesn’t… I have to go to the Edit menu and select "Paste Special" to paste the desired text. Even the normal Edit:Paste doesn’t work, it does the same thing as Insert key.

    Between yesterday and today, I have not:
    – rebooted my machine
    – installed any new software
    – closed/re-opened Me2006

    My antivirus is AntiVir PersonalPremium. I previously used Trend PcCillin 2007 and had the same problem. I have 500MB of free RAM and plenty of free disk.

    So why has ME changed its behavior?? Is there something I can do to get the normal Paste to work again??

    I would be *so* grateful if anyone has any ideas on this…

    #7444

    ChadW
    Participant

    Gorlash,

    Please see posting: http://www.multiedit.com/forums/viewtop … te+special

    #7445

    Gorlash
    Participant

    Okay, I read all that… I’m not sure what parts of it are relevant to my issue, since I’m copying from some other program, via the Windows clipboard. I looked at:
    TOOLS -> CUSTOMIZE -> EDITING -> BLOCKS
    (BTW, this pasted here when I did Control-V, but in ME it does *not* paste into the document when I select Edit:Paste !!),
    but I don’t see anything relevant to why Paste sometimes works and other times doesn’t…

    Could you clarify this?? And also clarify why it sometimes works and other times doesn’t??
    =============================
    Later:

    okay, I read in a little more detail… Indeed, when I quit and re-start ME, it is initially working. hmmm…. maybe I’ll try deleyd‘s idea of changing Insert to ALWAYS use Paste Special… I wonder what unwanted side effects that will have??

    #7459

    Gorlash
    Participant

    Okay, in summary, I added "paste special" to Control-V… if regular Paste fails, I use Control-V and that succeeds.

    I’d *still* really rather fix the problem, so Insert *always* does what it does by default, without breaking other things, but since that doesn’t appear to be possible, this will suffice.

    #7464

    Clay Martin
    Keymaster

    If you can attach paste-special command to Cntl-V, why don’t you attach that command to insert key. Tools-Customize-Keys/Commands Search for key insert (should be assigned to paste right?). Then change that to some other key combination, then search for name "paste special" and change its key assignment (edit) to the insert key. Then using insert should give you paste special each time.

    HTH,
    Clay

    #7465

    Gorlash
    Participant

    Well, I initially had done that (put Paste Special on Insert)… but in other cases that *doesn’t* do what I expect…

    Basically, I have two different situations that I’m dealing with here; my fundamental problem, I think, is that I don’t really understand how they differ:

    1. When I’m copying from an ME document and pasting into an ME document. All that has always worked fine.

    2. When I’m copying from some other application and pasting into an ME document. That works when I first start up ME, but then changes later because of something that I don’t understand. However, Paste Special *always* works as expected in situation 2.

    If I ALWAYS use Paste Special, then situation 1 doesn’t work properly. For example, I use Grey-+ to copy a line, and Insert to insert it (this is Brief behavior, and I use the Brief keymap). If I use Paste Special, the line is inserted in the middle of the current line at the cursor position, rather than being inserted as a separate line.

    hmmm… I wonder if it’s the Grey-+ operation which causes situation 2 to work differently?? lemme test that… no, that wasn’t it. I started a new ME session, and of course normal Paste (with an external copy) is working properly. I tried doing a line copy-and-paste within ME, then went back, copied something from a web page, and pasted into ME using normal Paste, and that’s still working at this point.

    SOMEWHERE, in my normal daily operation, I do SOMETHING which changes how ME is handling normal paste (relative to situation 2), but I don’t know what it is, which makes it hard to fix.

    Note that in both situations (working and broken) the Edit menu shows the current mark operation as "Mark Stream". Of course, that’s not entirely relavent, since it’s Paste, not Mark, that I’m having trouble with.

    Does anyone have any other ideas on what I could look at, to figure out how ME is handling Paste at a given moment??

    #7466

    Clay Martin
    Keymaster

    After refreshing myself on what was posted in the Chad referenced, it seems that the problems are:

    1 – ME copy places text (and copy style – stream, column or block) in the ME clip board (MEc) and in the windows clipboard (w/o style)
    2 – Paste special looks to the windows clipboard (Wc) first, thus if the copy was made in ME, the copy style is lost because Wc looses the style info. Thus if you did a block copy in ME, the paste ends up like if you did a stream copy.
    3 – Standard ME paste looks to the MEc first so if you did copy from outside ME, you get the last ME copy, not the windows copy.

    So until Dan updates ME either with using special Wc formats, or some code that looks at both Wc and MEc, and if the same text (plus a timestamp, or placing a hook on windows copy operations??) uses MEc by preference, a work around is needed.

    The work around Dan suggested places the processing on the human, and thus you must define two keys (like insert and Shft-insert) and use one or the other depending on where you did the copy.

    I hope this clears things up.

    BTW I have also noticed that at times (haven’t been able to reproduce faithfully, and I don’t use any clip board utilities, and almost always use stream blocks in ME) cut and regular paste ops work fine, whether copy from ME or outside source. Then suddenly (in middle of an edit session) to get text from outside source I must use paste special. This problem goes away on a ME restart. I also use project tied sessions like jeffstub mentioned in his post.

    #7467

    Gorlash
    Participant

    Thanks for your comments and insights, Clay!! For now, I’m using separate paste keys for the two paste functions, and that works fine. I really wanted an understanding of what was happening, and now I believe I have that!!

    #7474

    DanHughes
    Participant

    If anyone can determine what triggers the "Paste from Windows clipboard doesn’t work" issue, then please let me know as I want to find a better solution than the "Paste Special" workaround. I don’t believe I’ve ever seen the issue on any of my systems but I do have the other problem, where I loose the block mark style on pasting a Multi-Edit line block. I know what is causing this, my copy of Desktop Rover, but I haven’t found a fix that will work for this case and the other cases so I’ve had to live with using two keys for block pasting.

    #8787

    Lex
    Participant

    Is this problem anywhere near being fixed yet? It is most annoying!
    I am using ME Lite 2008, and I am still having the problem. Have previously had in under ME8 and ME9.
    Under Windows 7 it even seems worse than under XP (the problem seems to start happening much sooner in the editing session).
    Why is this so difficult to fix?

    #8915

    Tim-F
    Participant

    I am also experiencing this bug with Multi-Edit Lite 2008, version 11.04.00, installed on Windows 7. So far, I have never been able to determine a triggering condition. You can copy in another program and paste into ME from the Windows clipboard, and then suddenly you can’t. I have Multi-Edit open almost all day, except when I have to close it down and restart it to get paste capability again. If I can determine a pattern, I will post it here. Sure would be nice to see this bug solved!

    #8916

    Clay Martin
    Keymaster

    Hi,
    This is on our list of outstanding bugs to fix for the next release. Given that the ME kernel is getting a complete rewrite, this may get it done. Biggest problem with the bug is the difficulty reproducing it. One thought was it was to do with GUI system resources and the pascal based system used to build the kernel. With a different base used in the new build the problem may take care of itself.

    #8917

    jayterry
    Participant

    I see this issue on my system as well. However, I’ve found that even when Paste won’t work, Paste Special does work. So I’ve not reported a bug since I have a workaround until the new release.

    #9065

    LarryEdwards
    Participant

    As the first person in this thread said, "This is driving me NUTS!!!"

    It has been happening for me regualarly over the past several months, but for some reason was not a problem before.

    I would like to report one oddity. Last night I had both the current version of ME and ME-9.10 running (because there is a major bug in macro system in newer versions). I discovered that — in either version, it doesn’t matter which one — when the clipboard bug is occurring, if I open the window for the other version the text that is actually in the Windows clipboard will paste into that version’s window. I can then copy that text into the clipboard with CTRL-C and successfully paste it into the other version’s window with CTRL-V.

    To clarify what this means: If another version of ME is the "other" program, then copying from the Windows clipboard and back into the Windows clipboard works, and the Windows paste works in the target version of ME.

    This is a very clumsy work-around, but perhaps will get Multi-Edit tech support closer to a solution. Using paste-special instead of CTRL-V, as mentioned by someone above, is also a clumsy work-around.

    Can we please have a bug fix for this, instead of waiting for the "next release"?

    #9070

    Clay Martin
    Keymaster

    Hi,
    Possibly it is showing more because you upgraded to Win 7? I noticed that when I had XP, this might occur 2-3 times a year. Now it is very regular.

    I just restart Multi-Edit (ME) and it goes away for a while, and since I use sessions and session restore, it takes a second or two and everything (open files, cursor positions, etc.) is as it was when I closed ME.

    This bug is on the top of the bug list.

    Sorry for the inconvenience,
    Clay

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.