Prevent home key from going to top of screen or top of line?

Product Compare Forums Multi-Edit Support Prevent home key from going to top of screen or top of line?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2962
    LarryEdwards
    Participant

    How can I prevent multiple (accidental) hits on the home key from (on the second hit) taking me to the top of the screen and (on the third hit) top of the file.

    I also wish to stop the related actions with the end key and the mouse. (Not sure exactly what mouse action is triggering similar big jumps.)

    I know there is a way to do this, but sure can’t find it. Thx.

    #9559
    Bret Sutton
    Participant

    The Home key is assigned to the MeSys^Home macro, which takes a T= parameter. If this parm is set to zero or omitted, the behavior you describe should be eliminated.

    Ditto for the End key. I dunno about the mouse.

    If this doesn’t work for you, then it’s because of a change I made to these macros. I fixed ’em back in 1996. Let me know if you want me to send you copies of my updated macro source, and which version of Multi-Edit you’re running.

    #9560
    LarryEdwards
    Participant

    Thanks Bret. That does the trick. The integer to set is named Tn.

    #9561
    LarryEdwards
    Participant

    Hmm… I thought it worked, but actually it doesn’t. Can you send me your .S file?

    #9562
    LarryEdwards
    Participant

    Solved it. In the Home and End macros I commented-out these commands:

    Up;
    TOF;
    Down;
    EOF;

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.