question re mixing keyboard-emulation modes

Home Forums Multi-Edit Support question re mixing keyboard-emulation modes

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22170
    Gorlash
    Participant

    I’ve been using Brief emulation for years in MEW… however, recently I’ve been using other editors that don’t have Brief emulation, and have become accustomed to the standard Windows controls. I’d like to switch MEW to using Windows emulation, but I want to retain the numbered-bookmark selection commands. Is there any way I can manage that??

    #22202
    Clay Martin
    Keymaster

    Hi,
    To change the keyboard emulation go to Tools-Customize-General and press the … button next to Command set. But before you do that, I am assuming by “numbered-bookmark selection commands” you mean that you added some direct menu or key combos to the commands that set or go to a specific book mark number. The method to keep these depends on whether they are menu items or keystrokes. Please clarify.

    Thanks,
    Clay

    #22206
    Gorlash
    Participant

    Okay, to clarify, Brief emulation uses

    Alt-[0-9] to SET numbered bookmarks 0-9 (bookmark number is shown on left side of window)
    Alt-J-[0-9] to GOTO numbered bookmarks 0-9

    I want to switch to Windows keyboard emulation, but I want to add these bookmark-control key sequences (from Brief) to the Windows emulation.

    #22271
    Clay Martin
    Keymaster

    Ok, The easy way to do this is to go to Tools-Customize-Import/Export. Select commands from the drop down, then scroll down to Get random mark 0, select 0 thru 9 and press the right arrow button then scroll down and do the same with Set random mark 0 thru 9. Set the location of the export file in the selector in the upper right. Then press the export button. After you change your command set just come back to Import/Export and select the file and bring those command settings back.

    Let me know if this does not work for you, there may be issues where key maps overlap. If so there is a way to fix it after the change.

    Thanks,
    Clay

    #22278
    Gorlash
    Participant

    Okay, thanks… I’ll try this out, let you know how it works for me!

    #22377
    Gorlash
    Participant

    Okay, this “sort-of” worked… the SET commands Alt-1 through Alt-9, worked fine. However, the GET commands Alt-J+0 through Alt-J+9 did not… the GET commands show up in the Command Mapping list, but with no keys associated with them… I tried to assign new keys, but I don’t know how to handle the complex key mapping ( Alt-J plus key 0-9 ). Can you aid me with this??

    Actually, nevermind!! I changed the GET commands to Ctrl-1 through Ctrl-9, and that works fine!! That’s actually more remember-able than the originals anyway!!

    Thank you for your assistance with this issue…

    #22381
    Clay Martin
    Keymaster

    Good to hear. Just in case it comes up, to do something like Alt-J-0 go the keys/commands. Find the command, press edit then in the primary key press the … button and then type Alt-J, then in the secondary key press … and type 0.

    Thanks,
    Clay

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.