Record hook not freed??

Home Forums Multi-Edit Support Record hook not freed??

Viewing 15 posts - 91 through 105 (of 113 total)
  • Author
    Posts
  • #6390
    jbrandwood
    Participant

    Can someone from MESI please comment on this issue?

    Are there any plans to fix the problem (i.e. rewrite the code so that it doesn’t use the recording-hook)?

    If so, when?

    Thanks.

    #6455
    jbrandwood
    Participant

    Silence.

    Blank, deafening silence.

    I guess that the question has been answered.

    #6456
    ChadW
    Participant

    As noted before in prior postings within this very topic, MESI staff and users such as Michal Vodicka have noted that in order to remove the journaling hooks within Multi-Edit a major kernel rewrite will be required. We do plan to resolve these issues with the next major build of ME as we work to rewrite the entire kernel to resolve this and other limitations of the current kernel.

    #6465
    jbrandwood
    Participant

    Thanks for the clarification.

    I had been under the impression that ME 10 (ME2006) WAS the major rewrite. I stand corrected.

    I look forward to seeing how Multi-Edit progresses in the future, and will consider upgrading my personal licenses when these changes appear.

    In the meantime, like a number of other users throughout this two and a half year thread, I can wait no longer.

    I have switched my company’s Multi-Edit licenses to a competing product.

    #6612
    deleyd
    Participant

    Perhaps Multi-Edit could call GetLastError after a failed return from UnhookWindowsHookEx and display that info. It might help people to have as much info as possible about the error.

    #6613
    Michal Vodicka
    Participant

    This is what I suggested long time before and I’m surprised it wasn’t added to the code. Error number should be reported always when an OS API fails.

    Anyway, in this case it won’t give users any more info. The whole problem is bad design decision made long years ago when ME was ported from DOS to Windows. It is quite possible sufficient info about journaling hooks side effect wasn’t available then. Unfortunately, there isn’t an easy way how to fix it. The only thing users can do now is to find misbehaving app and don’t use it along with MEW keyboard macros.

    #7859
    lecroy
    Participant

    On these previous posts and in the 3 users I’ve had email in the error, we’ve been unable to reproduce the issue, but sending in and/or posting your Meconfig.db and Wcmdmap.db so myself, Development and others can take a look at the issue would be great.

    Like I said, we’ve only seen a handful of these errors and have not yet tracked down the cause, but attention to this has been passed on to the Dev Team and hopefully we’ll get to the bottom of this for you. In the interim, I’ve found that doing a clean install into a separate directory lets you get back to work and using the Macro recording feature again without issue and as the others in this post have mentioned, it doesn’t seem to be specifically an XP SP2 issue, so it may be something else, program or internal corruption of your current install.[/quote:1p41s9lp]

    I am seeing this same error after getting a new PC with IE7 using ME 8.0j.
    Has this been fixed in the latest version?

    #7860
    lecroy
    Participant

    Took the time to read this thread. I am happy that I never had a problem with it until now. But with so many years gone by I am a bit surprized there has never been a work around.

    I guess if you have the problem, the idea is your on your own to try an solve it. In my case, with the way we work now, I am stuck with what programs can and can not be installed and ran. We are using a lot of software to track what users are doing/have installed on their PCs. Plus, like I stated, all updates are now automatic. So, even if I determined the root cause, I most likely could not uninstall it.

    Welcome to the modern world of IT…..

    #7861
    Michal Vodicka
    Participant

    If you read this thread, you should understand there is no possible workaround. The only way how to solve the problem is major MEW kernel rewrite.

    #7863
    lecroy
    Participant

    If you read this thread, you should understand there is no possible workaround. The only way how to solve the problem is major MEW kernel rewrite.[/quote:2kjvm00q]

    I have not upgraded in about eight years, I was hoping that that this "major MEW kernel rewrite" was complete. I assume then that it won’t happen.

    #8188
    jc
    Participant

    I am able to reproduce this problem. I tried killing everything else I had running and found that the conflict was with Xming Server. Any chance this is fixed in the latest MEW version?

    #8190
    jc
    Participant

    Hello? (echo… echo…)

    #8264
    jc
    Participant

    Huh. I’ve been a ME user since version 7.0. I purchased 7.0 and have purchased two upgrades since. I’ve recommended ME to many of my colleagues.

    This, my first support question ever, was apparently not worthy of a reply. Guess what – I’m voting with my dollars and finding another editor.

    #8397
    dga
    Participant

    Well, I listen to the support and evaluate the 2008 version and this is still not working. No change since 9.10 something in 2005. The keyboard macro doesn’t work any more.

    I use multi edit since 1995 and this time I will vote with my wallet.

    As long as this bug is not corrected no money. You know how to contact me if you want to do a remote access for a check.

    space left intentionnaly blank

    Didier

    #8405
    edelwater
    Participant

    Hello,

    Sometimes I have this problem, but usually solves after a reboot.
    Today it was not … so I got crazy.
    After a while I found a reason. It was "Nokia PC Suite" active and listining on IrDA, USB and Serial ports.

    Just diabling all the listing ports and the macro recording magically re-start working as usual :)

    Hope this helps,
    [/quote:150mdkc1]

    I have the same problem and also nokia pc suite. I just rightclicked it and "close" but the error remains. Do I need to do something extra?

Viewing 15 posts - 91 through 105 (of 113 total)
  • You must be logged in to reply to this topic.