Right margin visibility

Product Compare Forums Multi-Edit Support Right margin visibility

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #776
    PaulMc
    Participant

    How do I turn off the visible right margin?

    How do I turn off the dashed box that surrounds the current line in a file?

    #3045
    AndyColson
    Participant

    Its actually set in the color setup. Goto Tools->Customize and hit the Colors button.

    Click on ‘Current line text’ and set its ‘control’ to ‘Off’. Do the same for ‘Right margin marker’

    -Andy

    #3049
    ReidSweatman
    Participant

    You can also at least put it out of sight by simply setting your right margin for any given extension to a high enough value to move the margin line off screen. Of course, if you actually use the right margin for anything, that will change, as well. But unless you’ve written any custom macros, it’s not likely.

    You actually only have to switch off Right Margin Marker to suppress the right margin from displaying.

    To turn off the dashed box around the current edit line, select Tools | Customize… from the main menu bar, then click on Windowing. Then uncheck the check box titled Outline current line.

    #3051
    PaulMc
    Participant

    Thanks Reid and Andy.

    I do a lot of hex-editing with ME and the outline box was annoying to the extreme. Reid’s method took care of that.

    A quick check of version 9 shows that a hex-edit problem I reported way back when in version 6 (and again in v7 and v8) has finally been resolved! I’ll be ordering before the day is out!

    #3052
    ReidSweatman
    Participant

    Just for my reference, what was the problem that got fixed? :?: Thanks.

    #3070
    PaulMc
    Participant

    Reid,
    The hex problem follows (a copy of the bug report submitted 2/3/1998). I’ve already ordered the upgrade and should be in heaven early this week!

    ==========================================

    Multi-Edit for Windows Bug Report Form (ver 1.2)

    pRoblem: Hex editing … FF converts to 0x20

    I use hex editing on files of records. Some of these files have records of
    varying length. To make it easier to view these records I’ll break the edit
    line … starting with something like this:

    AA 1A 00 AA 1B 00

    I might break after the first ’00’ which will give me this:

    AA 1A 00
    AA 1B 00

    If, however, I make the break right before an ‘FF’ ME converts this ‘silent’
    space to a hard space of ’20’. Like this:

    FF FE 00 FF FF 00

    will become:

    FF FE 00
    20 20 00

    This has been reported on CompuServe by myself, and others, since oh, version
    6 of ME-DOS. I’ve tried other hex editors but nothing, nothing, comes close to
    what ME can do. Resolve this one little problem and I’ll be in heaven!

    —————————————————————-
    Name: Paul McEvoy Email Addr: pmcevoy@channel1.com

    Machine: Myself P5-166-MMX 32 Mb
    Video Card: Stealth II 220
    Network: none

    Version: 8.0 Beta 5a OS: Win95a
    Install Dir: E:\MEW\ Network Drive: NO
    Command Map: WCMDMAP Enhanced Brief Mode: NO
    File Prompt: Classic

    And it also occurs in Beta 7.

    #3071
    ReidSweatman
    Participant

    Thanks for the info. I hadn’t been aware of that particular issue, and I’m glad it’s been fixed for you. The 0xFF character has a special meaning to Multi-Edit, but if you’ve opened a file in binary mode, the only way an 0xFF character could be present is if it were part of your data, as loading in binary mode prevents the normal translation of tab (0x09 or \t) characters into sequences of 0x09 followed by 0xFF that occurs when a file is loaded as a non-binary file (whether there are any tabs of any sort present will depend on the tab/space translation settings applicable to that file when it was last saved).

    Sorry for the lecture; I’ve given too many, and it gets to be a habit. :)

    Oh, totally OT, my brother, who’s a rock guitarist (yeah, the family shame…couldn’t be a decent rock keyboardist like me :lol: ) surfed through here the other day, and wondered about your alias, inasmuch as the very famous PaulMc… is known to be a computer buff. Anyway, he wanted me to ask. :oops: (No, really, it’s not for me; it’s for my sister-in-law’s kid brother… :D ). I told him, naw, the real PaulMc… wouldn’t use such an obvious alias; he’d use something like “Dirk McQuickly.” And on that totally obscure allusion, I hereby absquatulate from this thread.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.