Using Cmacwin properly

Home Forums Multi-Edit Support Using Cmacwin properly

This topic contains 1 reply, has 874 voices, and was last updated by  deleyd 9 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2639

    MewUser
    Participant

    Hello,

    I used a batch file for previous versions of MultiEdit to help me to debug my macros using cmacwin. The old .bat file would not work properly under Vista Ultimate 64 bit.

    The current memacrow.bat:

    cd \
    cd Program Files (X86)\Multi-Edit 2008
    cmacwin -l %1.s -D %2

    My macro file name is TestData.s, and when I run some macros in it, I get these messages:
    MultiEdit Error #8
    CopyDataToTextFile – PC = 1809
    Array index out of range

    When I click on OK, I get this message:
    MultiEdit Error #12
    Parse Data PC = 626
    Macro stack underflow

    I have tried running the memacrow.bat file

    memacrow TestData 1809

    This results in this:
    Multi-Edit Macro Compiler V11.04.00
    Compiling: ERROR OCCURRED: Compile did not complete
    File: TestData.s
    Line: Total: 9, This file: 0
    Message: TestData.s(1,1); ERROR 103: Invalid Debugging
    Invalid Debugging PC

    Any suggestions? I can compile the file just fine with MultiEdit using F9.

    Thank you.

    Mark

    #8781

    deleyd
    Participant

    could you post your TestData.s file? (or email it to me if you don’t want to post it?)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.