Why are tabs not on positions set by indent level?

Home Forums Multi-Edit Lite Support (Lite) Why are tabs not on positions set by indent level?

This topic contains 13 replies, has 14,490 voices, and was last updated by  Vincentcnbres 8 years, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #2334

    kevinhise
    Participant

    I don’t remember noticing it before, but tabs in MEL 2006 are like at 3 5 12 and 70, not evenly spaced at my tab setting (e.g. 4 chars). I think this happened before and the solution is to remove/reinstall?

    Kevin Hise

    #7814

    kevinhise
    Participant

    Now my tab settings are 3 and 70. It’s very odd to have to indent with the space bar because the tab key no longer works.

    Kevin Hise

    #7815

    Clay Martin
    Keymaster

    What is the tab settings for the extension you are editing? These are found in Tools-Customize-Extensions then pick the extension from the list and click on the edit button.

    The tab control box is on the left of the dialog.

    #7816

    kevinhise
    Participant

    There’s a box within the ‘Edit Filename Extension Setup’ dialog, and the settings are:

    (o) Use tab and margin settings
    Tab spacing [4]
    Right margin [80]
    ( ) Use format line
    [x] Expand to spaces

    I have always used this setting and have been able to manually control the tab alignment at an even 4 spaces (via tab or shift-tab) in MEW8. I thought this was working for a while, but I changed some colors a while back and the noticed that it’s now very inconsistent. I now have tab stops at 8, 59, and 65 (and they seem to change on their own).

    Kevin Hise.

    #7817

    kevinhise
    Participant

    I’ve gone back to my trusty copy of MEW32 and looked at the settings for it, and they’re the same. It seems to me I was curious at some point and ‘accidentally touched’ that ‘Use format line’ ‘Edit’ button, and once you’ve done that, something is mangled forever.

    Anyway, MEW32 works (although it cant syntax highlight HTML+Javascript very well, which is the reason I upgraded, but I don’t do that much anymore) so perhaps I’ll bail on MEL2006 (which oddly enough was buggy the first time I saw it in 1990 or so).

    Kevin Hise

    #7838

    kevinhise
    Participant

    I’ve deleted the Program Files/MEL2006 folder, and did a uninstall / reinstall, and strangely enough, I still have the same color scheme (which I don’t mind) and the same tab problem (which I do mind).

    What file in what directory do I delete or edit to fix the tab problem? I’ll go looking for it myself, but it would be helpful if someone (e.g. a tech) could point me in the right direction. Thanks.

    Kev.

    #7839

    kevinhise
    Participant

    Renamed

    documents and settings/user/application data/multi edit software/multi-edit lite

    to something like

    multi-edit lite…..bad

    Then run MEL again, it creates files with default values. Then went into MeConfig.db and copied my custom color and ‘customrgb.db’ sections to the new .db file. Now I have my colors back, and I’ll just avoid going into the config….unless *gulp* I have to.

    Kev.

    #7979

    bern
    Participant

    The exact same bug occurred to me in regular Multi Edit, not lite. I’m replying here since this thread covers the issue

    I changed the Edit Format line for a file extension and tried using it but now my tabs don’t work correctly (as described above) even when I go back to using the tab and margin settings.

    I really don’t want to reinstall from scratch because I don’t want to lose all my other customizations.

    I don’t understand why this thread has not been replied to my ME software. Looking at this thread, I see this issue has been around awhile and I wish ME software support would address it by either giving a permanent program fix or a workaround.

    Ignoring it is not an option. :(

    #7980

    DanHughes
    Participant

    I’ve tried to duplicate the problem described here with multiple versions of Multi-Edit and Multi-Edit Lite and I can’t do so. Could you send me your MeConfig.db file and what version of Multi-Edit you are using and what type of file is being edited, i.e. extension of the file.

    One thing to try is to go into Tools | Customize | General | Filename extension and select the extension that is having the problem. Then select the Edit button and select the Use format line option and check the format line using the Edit button beside it. Change it and hit the OK button and then save the dialog. Now do the same and return to using the "Use tab and margin settings" option. If you have a file loaded using the extension in question, you should be prompted with a Confirm dialog to reset the configuration for the file.

    #7981

    bern
    Participant

    I tried your suggestion, Dan but its still happening.

    I’m using version 10.05 on Win Home XP SP3.

    I rebuilt ME from scratch on a different directory and the tab issue went away. But when I copied the MeConfig.db file over from the previous directory the issue came back. Must be something in that file.

    I’m sending the complete ME to you at support @multiedit.com (subject line:To Dan Hughes).

    #8020

    DanHughes
    Participant

    Everyone having this issue should check to see if the Smart Tabs option is checked. It can be found in the Tools | Customize | Editing | Blocks | Smart Tab.

    The Smart Tab feature will cause the cursor to move over to the first non blank character of the previous lines.

    #8021

    bern
    Participant

    Thank you Dan. That fixed the issue.

    The documentation may need to be changed because, in my case anyway, the indent is set to non white space characters to not just the line above the current line, but to some other line depending on the length of the preceding lines.

    Then under Help | Contents | Index | Tab Spacing no mention is made that the block editing smart tab setting can have an effect on regular tab indents.

    Is this desired behavior? Should the block smart tab override all the file extension tab specifications? To me, smart tabs ruining extension tab settings seems harmful (if you don’t know about this behavior).

    Now that I know, I can always turn it off and on when needed.
    :)

    #9102

    Vincentcnbres
    Participant

    What file in what directory do I delete or edit to fix the tab problem? I’ll go looking for it myself, but it would be helpful if someone (e.g. a tech) could point me in the right direction. Thanks.

    #9099

    Clay Martin
    Keymaster

    Hi,
    Just go to Tools | Customize | Editing | Blocks and uncheck Smart Tab (bottom of options list).

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.