Untitled

Forum Replies Created

Viewing 15 posts - 1 through 15 (of 48 total)
  • Author
    Posts
  • in reply to: Multiedit and Clipboard Managers #7287
    sdw162006
    Participant

    There is some interaction between your clipboard manager and Multi-Edit, but I don’t know exactly what that is. What clipboard manager and version number are you using? What’s its website?

    Try changing the hotkey settings for paste. There are two commands that are normally used for pasting: "Paste from buffers", and "Paste special"
    Paste from buffers uses Multi-Edit’s internal buffer, and the Paste Special uses Windows clipboard. Paste from buffers is the default, to turn off its hotkey (or change it to Ctrl-Insert) then make the Paste Special hotkey Ctrl-V. See what difference that makes.

    Another thing to try, it to remove the hotkey from both those commands, so that within Multi-Edit Ctrl-V does nothing. This would normally put in the block character, but depending on how your clipboard manager interacts, this may work.
    Below are some general instructions for locating and changing hotkey assignments

    ‘Tools’ then ‘Customize’
    Select ‘General’ on the left, then click ‘Keys/Commands’
    Click the ‘search’ button
    Type in "paste" then click OK
    That will locate the next command named paste…

    Once you’ve located the command, select it, then click ‘Edit’. To change the hot key, press the ‘…’ button to the right of the ‘Primary key’ field, then enter the key combination, or click delete to remove the hotkey.

    in reply to: Windows Vista Compatibility #7286
    sdw162006
    Participant

    Yes, we know there are still issues with dual monitor support. Multi-Edit only receives display coordinates when a user moves the window around, then remembers those coordinates. ME has no idea what monitor number it is currently displaying on. Multi-Edit’s support of dual monitors currently supports remembering where to put dialogs (XY coordinates). For user’s going back and forth between dual and single monitor setups, this can be a problem.

    The problem was masked on our development machines because the video card driver handles remapping the windows to the proper display. That is done so that non dual-display capable programs are run on dual display computers, everything works out well.
    Not everyone is so lucky. As we found out, other video card drivers don’t handle the issue, and the individual programs must deal with the dual-monitors. Different video card drivers do different things in terms of what window coordinates the programs see, how to determine if a second monitor is enabled, if the second monitor is turned on, etc.

    We are working on a fix, to query the video card drivers and MS Windows about a second display being in use, the individual display dimensions, and changing the window coordinates each time the dialog displays. Unfortunately, the video card drivers do not always have accurate information about the second display. It is possible for the second monitor to be turned off or unplugged, and MS Windows will still tell us that dual display is enabled. Without knowing IF a second monitor is in use or not, ME will continue to display the dialog in the same position as last used.

    in reply to: Backwards Search Capability #7249
    sdw162006
    Participant

    The Ctrl-Alt-Up performs a different type of search.
    We currently don’t have a search function that searches backwards, without bringing up the search dialog and changing direction manually.

    Thank you for the suggestion. We will look into adding that functionality.

    in reply to: Lost all macros, keymaps, sessions, preferences #7185
    sdw162006
    Participant

    The updater has been fixed now. If you’d like to handle the settings yourself, follow these directions

    To migrate your settings:
    Close Multi-Edit
    Go to old Multi-Edit install directory
    Go into the config folder, select all (CTRL-A), copy (CTRL-C)
    Now open the user settings folder
    In XP C:\Documents and Settings\USERNAME\Application Data\
    In Vista C:Users\USERNAME\AppData\Roaming\
    From there, go into Multi-Edit’s settings
    Multi Edit Software\Multi-Edit\10\config
    Now paste (CTRL-V) all the files into this folder. This will copy all your settings over to the new location.
    Now run Multi-Edit, it will see the config files are of an older version, and update them.

    We apologize for the trouble, we changed where Multi-Edit stores configuration data, which is the first time we’ve done that, and we initially didn’t get the updater to look in the old location properly. The updater has been fixed now.

    The older versions, up to 10.03 stored configuration data in Multi-Edit_install_folder\config
    By default the install location was C:\Program Files\Multi-Edit (version). With Windows Vista, only installation programs, while using Administrator privileges, could write to the Program Files directory. That would not allow Multi-Edit to store configuration data there anymore. For Vista compatibility, we changed the config folder location to User_Settings\Multi-Edit\config

    in reply to: Can’t get tags to work (*.c *.h) #7106
    sdw162006
    Participant

    fixed in the 10.03 release

    in reply to: Delete word doesn’t always work correctly #7082
    sdw162006
    Participant

    Not really, for what the word delimiters are used for. Multi-Edit is designed with programmers in mind. Many programming languages have tools for processing text data. These in general allow the programmer to modify what delimiters are used. Many programmers would not like having that control taken away by a tool that says "All spaces are ignored".

    The delimiters are being used to say "these characters are separating words". Delimiters ALWAYS come between words, they separate them. Blank space generally (but not always) comes between words.

    Consider this command given on the Windows command prompt
    [code:2do6oh6q]cd program files\multi-edit 2006\[/code:2do6oh6q]
    Lets say that the delimiters are \:
    We have the words
    [code:2do6oh6q]cd[/code:2do6oh6q]
    [code:2do6oh6q]program[/code:2do6oh6q]
    [code:2do6oh6q]files[/code:2do6oh6q]
    [code:2do6oh6q]multi-edit[/code:2do6oh6q]
    [code:2do6oh6q]2006[/code:2do6oh6q]

    Lets say that the delimiters are \ : there is a [space] in there
    We have the words
    [code:2do6oh6q]cd program files[/code:2do6oh6q]
    [code:2do6oh6q]multi-edit 2006[/code:2do6oh6q]

    Does that make more sense as directories? But, if the [space] cannot be considered part of a word between "cd" and "program", then we’d have no command.
    So the [space] is being turned on and off as a delimiter while the command is being processed.

    To programmers, it makes perfect sense, and they expect, for [spaces] to be treated as a delimiter just as any other characters they choose. They expect ME’s word parser engine to behave and be configurable just as the parsers built into their programming languages.

    in reply to: MultiEdit Debug Error Message #7080
    sdw162006
    Participant

    Please email your MeConfig file to support@multieditsoftware.com
    The file is located in the folder \Multi-Edit\Config

    Also, tell us what operating system you are using, as well as what level service pack is installed. What version of Multi-Edit. How many files you may have open at the time, and what type of files (.c, .txt, .cpp, .java) as there may be some extension specific code involved.
    What debuggers are installed on your computer? Even if you’re not currently using them, they may have handlers connected with the task manager.

    in reply to: ERROR 3003 !!ME!!.TMP #7079
    sdw162006
    Participant

    David,
    I took your support call. Verify that ME is trying to open the file from the correct location. Meaning that user is the user’s correct account name
    C:\Documents and Settings\user\Application Data\Multi-Edit\Tags\!!ME!!.TMP

    Does the !!ME!!.TMP file actually exist in that location?

    Since we don’t have this issue normally, I’m wondering if it has something to do with how we got the installation to "work" using Windows Terminal Services.

    Just checking, are you running Windows Server 2000 or 2003?

    in reply to: Delete word doesn’t always work correctly #7077
    sdw162006
    Participant

    The delete word should delete from the cursor up to the next word. The ( is getting removed because it’s a not a word, rather it is a word delimiter, just as space and tab. The word is highlighted here
    [tab][space](-2)

    To get your desired behavior, you need to remove the () as word delimits. So you would have
    [code:1t4112o5]|9 ."’,$@!%^&*{}[]?/||;:+-<>~[/code:1t4112o5]

    Then Multi-Edit will treat the (-2) as a word.

    in reply to: Windows Vista Compatibility #7076
    sdw162006
    Participant

    If you have two versions of Multi-Edit installed, only the most recently installed will run.
    Example:
    If you install 10.03, then install 10.01 – only 10.01 will work. Installing 10.03 again will allow it to work, but disable 10.01
    We are working on determining how Vista is causing this, and what we can do about it.

    We have not encountered any problems with ME windows not appearing under Vista. Vespaman, please send a copy of your MeConfig file to support@multieditsoftware.com So we can attempt to duplicate the issue and fix it.
    The MeConfig file is located in the folder C:Program Files\Multi-Edit 2006\Config

    in reply to: Color Files #7063
    sdw162006
    Participant

    In the Multi-Edit\Config folder, in the file named MeConfig.db

    If you just want to save your color template, open MeConfig.db
    Search for colors.db
    Then look for the name of your template

    You can save that line as it’s own file, then it can be inserted into a MeConfig.db file later if anything happens or you fresh install

    in reply to: ME2006 Network Installation Problems #7060
    sdw162006
    Participant

    You as the administrator would login to each of the computers (all computers the users may use to log on). You will run the Net2006Setup.exe, which installs the Multi-Edit client onto the computer.

    All users of that computer can now run ME. They will be regular users, only access rights needed is for read/write to the configuration directory (local or server – that’s up to you)

    I don’t know exactly what you are meaning here

    terminal services so there is only one system32 directory and it’s the same computer that ME will be installed on[/quote:2ikkukel]

    but you won’t install a stand alone version on any computer that you are using network version on

    in reply to: Windows Vista Compatibility #7050
    sdw162006
    Participant

    Normann, sounds like you migrated your settings from windows XP, we’ll have to fix the settings updates for the next update

    Vista has changed where a users documents are stored, [code:i5c0f8v5]was C:\Documents and Settings\myName\My Documents
    now C:\Users\myName\Documents [/code:i5c0f8v5]

    try checking the option for "use path from last file"
    (tools | customize | files)

    that should change the path to where the current opened file is (assuming you’ve opened a file first, not a new file)

    once you’ve got the Open dialog up, use the button to the right of the working directory field labeled
    Viewed directory -> Working directory
    to set the working directory to c:\users\……
    so that next time you have a new file, it will try to open that folder, rather than the non existent XP folder

    in reply to: Windows Vista Compatibility #7038
    sdw162006
    Participant

    Some users are getting an error on startup of ME, Vista shows a dialog that multiedit has stopped working, looking for solution. In the background the ME
    splashscreen is up.

    After pressing debug, It says "An unhandled win32 exception occurred in
    Mew32.exe [5388]

    We are working toward finding the cause of this error.

    in reply to: Simple regular expression search question #7031
    sdw162006
    Participant

    Check what style of search you are using. On the search dialog, click the option tab at the upper right, look at the ‘Regular Expression Type’

    If you are using classic regular expressions then this will work
    [code:olcnzl45]{class}|{struct}[/code:olcnzl45]

    If you are using Perl style regular expressions than either of these will work
    [code:olcnzl45]class | struct
    class|struct[/code:olcnzl45]

Viewing 15 posts - 1 through 15 (of 48 total)